Frédéric Laubel's Blog

Exchange Server Tips & Tricks

Exchange 2010 SP1 : Erreur Get-LogonUser

Posted by Frédéric Laubel sur novembre 25, 2010


Après le passage du SP1 vous pouvez obtenir l’erreur suivante lors du lancement de la console Exchange :

The following error occured when retrieving user information for ‘Domain\administrator’
The operation could not be performed because object ‘s-1-x-xx-xxxxxxxxxxxx-xxxxxxxxxxxx’ couldnt be found on xxx.domain.com. It was running command Get-LogonUser.

Ce message apparait si le système d’exploitation sur lequel est installé Exchange 2010 SP1 est issu d’un clone (genre Ghost, copie ou template de VM…) qui n’a pas été préparé avec SYSPREP, ou qui n’a pas été correctement préparé avec SYSPREP. Dans ce cas il y a un conflit de SID qui provoque ce message.

La seule solution pour éviter ce problème est d’utiliser SYSPREP en prenant soin de choisir l’option GENERALIZE.

Sur Windows Server 2008 R2, SYSPREP se trouve dans C:\windows\system32\sysprep :

Lancer l’utilitaire avec les options OOBE et Generalize :

Vous pouvez ensuite joindre la machine dans le domaine et installer Exchange 2010 SP1.

Rappels et conseils :

  • SYSPREP doit être utilisé avant l’installation d’Exchange, quand la machine n’est pas encore dans le domaine
  • Vous devez utiliser l’option GENERALIZE
  • Vous ne pouvez pas utiliser l’utilitaire NewSID – de Sysinternals/Microsoft – sur Windows 2008 R2
  • Vous ne DEVEZ PAS utiliser l’utilitaire NewSID sur les autres version de Windows !
  • Vous devez utiliser SYSPREP à chaque fois qu’un changement de SID est nécessaire
  • Vous ne DEVEZ pas utiliser SYSPREP une fois Exchange installé


3 Réponses to “Exchange 2010 SP1 : Erreur Get-LogonUser”

  1. Nicolas said

    Ce problème m’a bloqué toute l’aprem !

    attention au copié collé de VM !

    merci !

  2. Bonjour Frédéric,

    Newsid fonctionne pourtant toujours très bien! Même s’il faut préférer SYSPREP évidemment.

    A+
    T.DEMAN

    • Frédéric Laubel said

      Bonjour Thierry,

      Ça fait plaisir de te voir par ici !🙂
      Sur du W2K8R2 il plante et provoque de gros soucis, genre crash du système. Si tu n’as pas rencontré cela estime toi chanceux🙂

Sorry, the comment form is closed at this time.

 
%d blogueurs aiment cette page :